スポンサーサイト

-- --, --
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

wordpress プラグインアップデート時の注意

12 04, 2010

wordpress3.0.1 を使っているのですが、いくつかのプラグインをアップデートしたところ、画面に

Your PHP version is too old, please upgrade to a newer version. Your version is 5.1.x, this plugin requires 5.2.0

と表示され、ログインすら出来なくなりました。

調べてみると、プラグインによっては、PHPのバージョン5.1.xでは使えないものがあるそうです。

プラグインをアップデートしたことによってHP5.1.xでは使えなくなってしまったようです。

じゃあPHPのバージョンアップをするか、と思いきや、借りているサーバはPHPのバージョンアップはサポート外。やってもいいけど問題が発生してもしりませんとのこと。

これは困った。どのプラグインなのか分からないし。

ということで、FTPでログインしてpluginsフォルダの中身を全部削除してpluginsフォルダを空に。

必要最低限のプラグインを一個ずつインストールしてみるが問題なし。使わないプラグインはインストールせず。

はたしてどのプラグインが原因だったのか分からずじまい。

これからはアップデートは慎重に。

 

もうひとつ気をつけること。来年2011年リリース予定のWordPress 3.2 はPHPの最低バージョンが5.2に引き上げられます。

2011年上半期リリース予定の WordPress 3.2 では、PHP の動作要件の最低バージョンが 5.2 に引き上げられます。なぜ 5.2 なのか?それは WordPress ユーザーの大半が使用しているからであり、PHP 5がこれまでのリリースわたって大幅に改善されているからです。また、今年リリース予定の Drupal と Joomla の次のバージョンがサポートするPHPの最小バージョンでもあるからです。

PHP5.1.x を使っている場合は、WordPress 3.2 にアップグレードは出来ないということです。

それとMySQLの最低バージョンも5.0.15になるそうです。

2011年前半にリリース予定の WordPress3.2 では PHP 5.2 以上、MySQL 5.0.15以上が必要になります。ヘルスチェックプラグインをインストールして、準備が整ったか確認してみましょう!

と言うわけで確認してみました。

php-1

残念でした。使っているサーバは、WordPress 3.2 にアップグレード出来ず。

追記

その後、調べてみましたが、パンくずリストを表示するプラグインが原因でした。

Breadcrumb NavXT

コメント欄に対処法が書かれていました。

レンタルサーバー ヘムテル

引用

.htaccess ファイルで指定する方法

下記からダウンロードした zip ファイルを解凍し、『 .htaccess 』 ファイルを、PHP5 をご利用頂きたいディレクトリに配置してください。
もし全ての PHP ファイルを PHP5 で動作させたい場合は WEB ディレクトリに .htaccess を配置してください。

.htaccess の内容

AddHandler php5-script .php

.htaccess ファイルのダウンロードはこちらです

-0 Comments
Leave a comment
管理者にだけ表示を許可する
-0 Trackbacks
Top
RSSフィード
プロフィール

空間建築ファクトリー

ロゴ

空間建築ファクトリー
空間建築ファクトリーのスタッフ日記です。
仕事とは関係のないことなんか書いてますよ。

東急線 賃貸
東急すまっぷ
カテゴリー
最近の記事
ブロとも申請フォーム
リンク
お引っ越しなら
アーク引越センター
trackword
    上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。